>source

Cannot find a version of 'com.google.code.findbugs:jsr305' that satisfies the version constraints

  Dependency path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305:3.0.2'
   Constraint path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305' strictly '1.3.9' because of the following reason: debugRuntimeClasspath uses version 1.3.9
   Dependency path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305:3.0.2'
   Constraint path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305' strictly '1.3.9' because of the following reason: debugRuntimeClasspath uses version 1.3.9
   Dependency path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305:3.0.2'
   Constraint path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305' strictly '1.3.9' because of the following reason: debugRuntimeClasspath uses version 1.3.9
   Dependency path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305:3.0.2'
   Constraint path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305' strictly '1.3.9' because of the following reason: debugRuntimeClasspath uses version 1.3.9
   Dependency path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305:3.0.2'
   Constraint path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305' strictly '1.3.9' because of the following reason: debugRuntimeClasspath uses version 1.3.9
   Dependency path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305:3.0.2'
   Constraint path 'Kmrider5:app:unspecified' --> 'com.google.code.findbugs:jsr305' strictly '1.3.9' because of the following reason: debugRuntimeClasspath uses version 1.3.9
   Dependency path 'Kmrider5:app:unspecified' --> 'com.android.support.test.espresso:espresso-core:3.0.2' --> 'com.google.code.findbugs:jsr305:2.0.1'
   Dependency path 'Kmrider5:app:unspecified' --> 'com.google.android.libraries.places:places:1.0.0' --> 'com.google.guava:guava:23.5-android' --> 'com.google.code.findbugs:jsr305:1.3.9'


  • 답변 # 1

    아마도 움직 였기 때문일 것입니다. 여기에 링크가 설명되어 있습니다.

    https://code.google.com/archive/p/findbugs/

  • 답변 # 2

    'com.google.code.findbugs : jsr305'에 따라 일부 gradle 라이브러리를 가져오고 있지만 버전. 라이브러리 버전을 업데이트할지 또는 일부에서 findbugs 라이브러리의 암시 적 가져 오기를 제외할지 평가해야합니다.

    이미 작성된 프로젝트에 Espresso를 추가하고 Espresso의 라이브러리 가져 오기에서 findbugs를 제외하여이 오류가 발생했습니다.

    솔루션

    androidTestImplementation 'com.android.support.test.espresso:espresso-contrib:3.0.2', {
        exclude group: 'com.google.code.findbugs', module: 'jsr305'
    }
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2', {
        exclude group: 'com.google.code.findbugs', module: 'jsr305'
    }
    
    

  • 이전 sql - 파티션에서 행 필터링
  • 다음 Net Core SignalR을 사용하여 지속적으로 업데이트를 보내는 방법은 무엇입니까?