>source

Symfony를 처음 사용하여 설치하려고했습니다. symfony/maker-bundle , 그러나 다음과 같은 오류가 발생합니다.

Using version ^1.22 for symfony/maker-bundle
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Restricting packages listed in "symfony/symfony" to "4.4.*"
Your requirements could not be resolved to an installable set of packages.
  Problem 1
    - ocramius/proxy-manager 2.9.0 requires composer-runtime-api ^2.0.0 -> no matching package found.
    - ocramius/proxy-manager 2.9.0 requires composer-runtime-api ^2.0.0 -> no matching package found.
    - ocramius/proxy-manager 2.9.0 requires composer-runtime-api ^2.0.0 -> no matching package found.
    - Installation request for ocramius/proxy-manager (locked at 2.9.0) -> satisfiable by 
ocramius/proxy-manager[2.9.0].

비슷한 문제를 검색했는데 종종 패키지 버전을 composer.json 하지만 둘 다 찾을 수 없습니다 ocramius/proxy-manager ...도 아니다 composer-runtime-api 그것에 :

{
"type": "project",
"license": "proprietary",
"require": {
    "php": "^7.1.3",
    "ext-ctype": "*",
    "ext-iconv": "*",
    "ext-simplexml": "*",
    "bluetel-solutions/twig-truncate-extension": "^0.1.3",
    "friendsofsymfony/rest-bundle": "^2.7",
    "jms/serializer-bundle": "^3.5",
    "liip/imagine-bundle": "^2.2",
    "sensio/framework-extra-bundle": "^5.4",
    "symfony/apache-pack": "^1.0",
    "symfony/asset": "4.4.*",
    "symfony/console": "4.4.*",
    "symfony/dotenv": "4.4.*",
    "symfony/flex": "^1.3",
    "symfony/form": "4.4.*",
    "symfony/framework-bundle": "4.4.*",
    "symfony/mailer": "4.4.*",
    "symfony/monolog-bundle": "^3.4",
    "symfony/orm-pack": "^1.0",
    "symfony/security-bundle": "4.4.*",
    "symfony/security-csrf": "4.4.*",
    "symfony/serializer": "4.4.*",
    "symfony/swiftmailer-bundle": "^3.4",
    "symfony/translation": "4.4.*",
    "symfony/twig-bundle": "4.4.*",
    "symfony/validator": "4.4.*",
    "symfony/webpack-encore-bundle": "^1.7",
    "symfony/yaml": "4.4.*",
    "twig/extensions": "^1.5",
    "vich/uploader-bundle": "^1.12",
    "whatwedo/core-bundle": "dev-symfony5",
    "whatwedo/search-bundle": "dev-symfony5"
},
"require-dev": {
    "symfony/maker-bundle": "^1.12",
    "symfony/web-server-bundle": "4.4.*"
},
"config": {
    "preferred-install": {
        "*": "dist"
    },
    "sort-packages": true
},
"autoload": {
    "psr-4": {
        "App\\": "src/"
    }
},
"autoload-dev": {
    "psr-4": {
        "App\\Tests\\": "tests/"
    }
},
"replace": {
    "paragonie/random_compat": "2.*",
    "symfony/polyfill-ctype": "*",
    "symfony/polyfill-iconv": "*",
    "symfony/polyfill-php71": "*",
    "symfony/polyfill-php70": "*",
    "symfony/polyfill-php56": "*"
},
"scripts": {
    "auto-scripts": {
        "cache:clear": "symfony-cmd",
        "assets:install %PUBLIC_DIR%": "symfony-cmd"
    },
    "post-install-cmd": [
        "@auto-scripts"
    ],
    "post-update-cmd": [
        "@auto-scripts"
    ]
},
"conflict": {
    "symfony/symfony": "*"
},
"extra": {
    "symfony": {
        "allow-contrib": false,
        "require": "4.4.*"
    }
}

다른 버전이 필요할 수 있습니다. symfony/maker-bundle ?


  • 답변 # 1

    Ocramius는 이전 버전과의 호환성을 유지하는 가혹한 입장으로 잘 알려져 있습니다.

    이 경우 릴리스 2.9.0은 다음과 같이 말합니다.

    This release upgrades ocramius/proxy-manager 사용 composer-runtime-api:^2 : 이 당신이 필요하다는 것을 의미합니다 composer:^2 이 버전의 ProxyManager를 설치합니다.

    composer v2로 업그레이드하려면 다음을 실행할 수 있습니다. composer self-update --2 너의 개발 또는 CI/CD 시스템.

    따라서 옵션은 다음과 같습니다.

    composer를 버전 2 ( composer self-update --2 ), 실제로 필요하고 새 릴리스를 고려하도록 업데이트되지 않은 특정 작곡가 플러그인이없는 한 정말 권장되는 방법입니다.

    설치중인 패키지가 프록시 관리자 ( composer why ocramius/proxy-manager )의 이전 (<2.9) 버전에 종속되도록 해당 패키지에 대한 버전 제약 조건을 조정할 수 있는지 확인합니다. ocramius/proxy-manager . (완벽 함을 위해서만이 옵션을 언급하지만 composer를 업그레이드하는 것이 정말 좋은 방법입니다.)

  • 이전 Visual Studio/C ++에서 fbx SDK를 사용하여 프로젝트를 빌드 할 때 컴파일 오류
  • 다음 python - 이진 검색 트리의 최소 요소