>source

안녕하세요

jupyter 노트북에서 아래와 같이 tensorflow를 가져 오려고 할 때 ModuleNotFoundError : No module named 'tensorflow'라는 오류가 발생했습니다. 그런 다음 anaconda 프롬프트를 열고 anaconda에 tensorflow를 설치하려고 시도했지만 여러 번 실패했으며 여기에 오류 메시지가 있습니다. 문제가 무엇인지 도와 주시겠습니까? 감사

import tensorflow as tf

좋아, 그래서 파이썬을 3.8에서 3.6으로 다운 그레이드하려고 시도했지만 결국 오류가 발생했습니다. 누구나 pls를 도울 수 있습니까? 감사

EnvironmentNotWritableError : 현재 사용자에게 대상 환경에 대한 쓰기 권한이 없습니다. 환경 위치 : C : \ ProgramData \ Anaconda3

  • 답변 # 1

    TensorFlow 문서에 따르면 tf는 python 3.5, 3.6, 3.7 또는 3.8과 호환됩니다. 또한 python 3 64bit 릴리스는 필수이므로 32bit 버전의 python에 실수로 tf를 설치하지 않는지 확인하는 것이 좋습니다. https://www.tensorflow.org/install/pip#windows

    import sys
    print(sys.version)
    
    

    Anaconda 문서에 따라 tf를 설치했습니다. 신선한 환경을 만들고, 활성화, tf :

    conda create -n myproject tensorflow
    conda activate myproject
    conda install tensorflow
    
    

    conda가 자동으로 Python 버전 3.7.9를 선택했음을 알 수 있습니다.

    확인:

    import tensorflow as tf
    tf.version.VERSION
    
    

  • 답변 # 2

    너의 python 버전이 호환되지 않습니다 tensorflow . 파이썬 3.8을 사용하고 있습니다. 3.5, 3.6 or 3.7 . 좌초 python 문제를 해결해야합니다.

  • 답변 # 3

    이것을 시도 할 수 있습니다.

    pip install tensorflow==2.0
    
    

관련 자료

  • 이전 javascript - typeerror - reactdatagrid에서 undefined 속성 'length'를 읽을 수 없습니다
  • 다음 특정 단어와 연속 된 여러 줄이 포함 된 줄을 복제하려면 어떻게해야합니까 (예 - awk 또는 sed 사용)?