>source

QML을 설치하려고 하면 다음과 같은 결과가 나타납니다.

(Tibra.jl) pkg> add QML
   Resolving package versions...
ERROR: Unsatisfiable requirements detected for package Flux [587475ba]:
 Flux [587475ba] log:
 ├─possible versions are: 0.4.1-0.12.9 or uninstalled
 ├─restricted to versions * by an explicit requirement, leaving only versions 0.4.1-0.12.9
 ├─restricted by compatibility requirements with Requires [ae029012] to versions: 0.8.3-0.12.9 or uninstalled, leaving only versions: 0.8.3-0.12.9
 │ └─Requires [ae029012] log:
 │   ├─possible versions are: 0.5.0-1.3.0 or uninstalled
 │   └─restricted by compatibility requirements with QML [2db162a6] to versions: 1.0.0-1.3.0
 │     └─QML [2db162a6] log:
 │       ├─possible versions are: 0.6.0-0.7.0 or uninstalled
 │       └─restricted to versions * by an explicit requirement, leaving only versions 0.6.0-0.7.0
 ├─restricted by compatibility requirements with CUDAapi [3895d2a7] to versions: [0.4.1-0.8.3, 0.10.0-0.12.9] or uninstalled, leaving only versions: [0.8.3, 0.10.0-0.12.9]
 │ └─CUDAapi [3895d2a7] log:
 │   ├─possible versions are: 0.5.0-4.0.0 or uninstalled
 │   └─restricted by julia compatibility requirements to versions: uninstalled
 ├─restricted by compatibility requirements with CuArrays [3a865a2d] to versions: [0.4.1-0.8.3, 0.11.0-0.12.9] or uninstalled, leaving only versions: [0.8.3, 0.11.0-0.12.9]
 │ └─CuArrays [3a865a2d] log:
 │   ├─possible versions are: 0.2.1-2.2.2 or uninstalled
 │   └─restricted by julia compatibility requirements to versions: uninstalled
 ├─restricted by compatibility requirements with NNlib [872c559c] to versions: 0.8.3-0.11.6 or uninstalled, leaving only versions: [0.8.3, 0.11.0-0.11.6]
 │ └─NNlib [872c559c] log:
 │   ├─possible versions are: 0.3.2-0.8.0 or uninstalled
 │   ├─restricted by compatibility requirements with Flux [587475ba] to versions: 0.3.2-0.8.0
 │   │ └─Flux [587475ba] log: see above
 │   ├─restricted by compatibility requirements with Requires [ae029012] to versions: 0.6.0-0.8.0 or uninstalled, leaving only versions: 0.6.0-0.8.0
 │   │ └─Requires [ae029012] log: see above
 │   ├─restricted by compatibility requirements with Compat [34da2185] to versions: [0.3.2-0.7.6, 0.7.10-0.7.11] or uninstalled, leaving only versions: [0.6.0-0.7.6, 0.7.10-0.7.11]
 │   │ └─Compat [34da2185] log:
 │   │   ├─possible versions are: 1.0.0-3.41.0 or uninstalled
 │   │   └─restricted by compatibility requirements with TerminalMenus [dc548174] to versions: 1.0.0-2.2.1
 │   │     └─TerminalMenus [dc548174] log:
 │   │       ├─possible versions are: 0.1.0 or uninstalled
 │   │       └─restricted to versions * by an explicit requirement, leaving only versions 0.1.0
 │   └─restricted by compatibility requirements with LoopVectorization [bdcacae8] to versions: [0.3.2-0.7.1, 0.7.4-0.8.0] or uninstalled, leaving only versions: [0.6.0-0.7.1, 0.7.4-0.7.6, 0.7.10-0.7.11]
 │     └─LoopVectorization [bdcacae8] log:
 │       ├─possible versions are: 0.1.0-0.12.101 or uninstalled
 │       └─restricted by julia compatibility requirements to versions: 0.9.0-0.12.101 or uninstalled
 ├─restricted by compatibility requirements with CUDA [052768ef] to versions: [0.4.1-0.10.4, 0.12.2-0.12.9] or uninstalled, leaving only versions: 0.8.3
 │ └─CUDA [052768ef] log:
 │   ├─possible versions are: 0.1.0-3.8.0 or uninstalled
 │   ├─restricted by julia compatibility requirements to versions: [2.3.0, 2.5.0-3.8.0] or uninstalled
 │   └─restricted by compatibility requirements with LLVM [929cbde3] to versions: 3.3.3-3.8.0 or uninstalled
 │     └─LLVM [929cbde3] log:
 │       ├─possible versions are: 0.9.0-4.7.1 or uninstalled
 │       └─restricted by julia compatibility requirements to versions: 4.0.0-4.7.1 or uninstalled
 └─restricted by compatibility requirements with Colors [5ae59095] to versions: 0.10.4-0.12.9 or uninstalled — no versions left
   └─Colors [5ae59095] log:
     ├─possible versions are: 0.9.0-0.12.8 or uninstalled
     ├─restricted by compatibility requirements with Flux [587475ba] to versions: 0.9.0-0.12.8
     │ └─Flux [587475ba] log: see above
     └─restricted by compatibility requirements with ColorTypes [3da002f7] to versions: 0.12.0-0.12.8 or uninstalled, leaving only versions: 0.12.0-0.12.8
       └─ColorTypes [3da002f7] log:
         ├─possible versions are: 0.7.0-0.11.0 or uninstalled
         └─restricted by compatibility requirements with QML [2db162a6] to versions: 0.10.0-0.11.0
    └─QML [2db162a6] log: see above

  • 답변 # 1

    깨끗한 환경에서 재현할 수 없기 때문에 문제가 간접적인 것 같습니다. 노력하다:

    ]
    activate --temp
    add QML
    add Flux
    

    어디서]입력하는 것입니다패키지> REPL 모드

  • 이전 python : 반환 후/반환과 함께 code를 실행하기 위해 스레드를 사용하는 플라스크
  • 다음 javascript : PHP base_url 함수에 대한 변수 값