>

NAS에서 SSH를 사용할 수있는 유일한 사용자는 'root'와 'admin'입니다.
지금까지 내가 본 답변은 this 와 같습니다. /etc/ssh/sshd_config 에서 설정 한 곳  같은

AllowUser userName
PermitEmptyPasswords yes

/etc/ssh/ 디렉토리가 없습니다  하지만 sshd_config 파일을 찾았습니다   /etc/ 에서 . 나는 후자를하고 'AllowUser'에 추가했기 때문에 추가했습니다. 재부팅했는데 문제가 지속됩니다.

  • ssh에 다른 "맛"이 있습니까?
  • 그렇다면, 내가 가진 것에 대해 어디서 배울 수 있습니까? (NAS 쉘에는 '남자'가 없습니다)

우분투 16.04에서 Western Digital MyBook 모델 # WD10000H1NC-00으로 SSH 연결 중입니다.
더 많은 정보가 필요하면 알려주십시오.

  • 답변 # 1

    먼저 AllowUser userName 를 변경해보십시오   /etc/sshd_config 에서   AllowUsers root admin userName 에 당신의 WD 나의 책에 파일  문제가 해결되는지 확인하십시오.

    또한 /etc/passwd 의 내용을 확인하십시오   userName 에 대한 항목을 확인하십시오   /user/sbin/nologin 를 포함하지 않습니다 대신 /bin/bash 와 같은 것 . 예를 들어, 내 WD MyCloud의 관리자 계정 항목은 다음과 같습니다.

    admin:x:999:1000::/shares:/bin/sh
    
    
    ssh 의 풍미에 대해 더 배우는 것에 관해서 연결을 시작할 때 -v 를 추가 할 수 있습니다  상세 출력용 플래그 (또는 심지어 -vvv )  원하는 경우 더 많은 출력을 얻으려면) :

    ssh -v root@WD_MyBook_IP
    
    

    NAS에 연결하면 아래 출력이 표시됩니다. 이것은 내 로컬 시스템이 OpenSSH_6.6.1 를 사용한다는 것을 알려줍니다.  내 NAS는 OpenSSH_6.0p1 Debian-3 를 사용합니다 .

    ssh -v root@ip_address
    OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 19: Applying options for *
    debug1: Connecting to 192.168.0.20 [192.168.0.20] port 22.
    debug1: Connection established.
    ------------Truncated---------------
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2.7
    debug1: Remote protocol version 2.0, remote software version OpenSSH_6.0p1 Debian-3
    
    

  • 이전 linux kernel - RT_PREEMPT 적용
  • 다음 networkmanager - 오픈 수세 - 네트워크 문제