>

최종 Unity (2018.1)를 다운로드하고 스크립팅 런타임 버전을 4.x로 변경했습니다.

그러나 프로젝트에 어떤 System.Data.dll을 포함시켜야하는지 찾을 수 없습니다 (System.Data.SQLite 라이브러리에 필요).

Unity 폴더를 체크인하면 MonoBleedingEdge/lib/mono에 많은 폴더가 있습니다 : 4.0, 4.0-api, 4.5, 4.5.1-api ...

해당 폴더에있는 몇 가지 System.Data.dll을 사용해 보았습니다

항상 "스크립트 어셈블리로드 중"Assets/Plugins/System.Data.dll "이 실패했습니다!" 게임을 실행할 때 왜 그런지 아십니까? 또는 더 많은 세부 정보를 가질 가능성이 있습니까? (예상되는 dll 버전)


  • 답변 # 1

    내 주 여행 :

    스택 오버플로

    통일 답변

    솔루션 :

    마침내 알아내는 데 일주일이 걸렸습니다 ...

    다음을 사용해야합니다 :

    I18N.dll

    I18N.West.dll

    I18N. *. dll (선택 사항, 지역에 따라 다름)

    System.Data.dll

    C : \ Program Files \ Unity \ Editor \ Data \ Mono \ lib \ mono \ 2.0에서

    BleedingEdge 경로를

    아닙니다. 그러면 오류없이 작동합니다 ... 최신 Unity 2018.2.6f1에서 확인되었습니다.

  • 답변 # 2

    System.Data 를 교체하려고하면 어떻게됩니까?  여기

    /Applications/Unity/Hub/Editor/2018.1.0b11/Unity.app/Contents/MonoBleedingEdge/lib/mono/unity

    참고 :Unity HUb를 설치했지만 경로는 비슷해야합니다

  • 이전 java - printf 포맷터를 파일로 받아들이지 않는 인쇄기 출력?
  • 다음 javascript - Xpage에서"Repeatagent"를 실행하십시오