>

데비안 서버에 이상한 일을했는데 지금은 아무것도 설치할 수 없습니다. 로케일이 고장 났다고합니다. dpkg를 재구성하고, apt-get 및 기타 많은 솔루션을 인터넷에서 정리하여 문제를 해결하려고했습니다. 설치하려고하면 다음과 같은 결과가 나타납니다.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  locales
The following packages will be upgraded:
  xxx yyy
xx upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 27.3 MB of archives.
After this operation, 19.3 MB disk space will be freed.
Do you want to continue? [Y/n]
Fetched 27.3 MB in 19s (1,396 kB/s)
(Reading database ... 45726 files and directories currently installed.)
Removing locales (2.19-18+deb8u2) ...
dpkg: error processing package locales (--remove):
 cannot remove '/usr/share/locale/locale.alias': Input/output error
Errors were encountered while processing:
 locales
E: Sub-process /usr/bin/dpkg returned an error code (1)
apt-get upgrade  10.60s user 2.89s system 40% cpu 32.969 total

이러한 오류로 인해이 파일을 제거 할 수 없습니다.
로케일 파일을 수정하거나 다시 실행하려고하면 locales is broken or not fully installed 가 말합니다.   

의견에서 제안한대로 :

root@bananapi ~ # dpkg --audit
The following packages are only half installed, due to problems during
installation.  The installation can probably be completed by retrying it;
the packages can be removed using dselect or dpkg --remove:
 locales              GNU C Library: National Language (locale) data [support]

이 작업을 시도했지만이 오류가 발생합니다 :

1 root@bananapi ~ # apt-get install locales                                                                                                                                                              :(
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  locales
1 upgraded, 0 newly installed, 0 to remove and 17 not upgraded.
1 not fully installed or removed.
Need to get 3,944 kB of archives.
After this operation, 395 kB of additional disk space will be used.
Get:1 http://security.debian.org/ jessie/updates/main locales all 2.19-18+deb8u3 [3,944 kB]
Fetched 3,944 kB in 1s (3,045 kB/s)
Preconfiguring packages ...
Selecting previously unselected package locales.
(Reading database ... 45727 files and directories currently installed.)
Preparing to unpack .../locales_2.19-18+deb8u3_all.deb ...
Unpacking locales (2.19-18+deb8u3) over (2.19-18+deb8u2) ...
dpkg: error processing archive /var/cache/apt/archives/locales_2.19-18+deb8u3_all.deb (--unpack):
 unable to make backup link of './usr/sbin/update-locale' before installing new version: Too many links
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/locales_2.19-18+deb8u3_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
apt-get install locales  5.53s user 1.97s system 34% cpu 21.697 total

  • 답변 # 1

    와이즈 비즈 와이즈 비즈

    포장 시스템에는 문제가 없습니다. 저장소가 손상되었습니다. 스토리지의 손상된 부분에 액세스해야하는 것은 실패합니다. 이 경우 업그레이드시 손상된 디렉토리의 파일을 교체해야합니다.

    손상된 저장소는 잘못된 신호입니다. 디스크를 교체하고 데이터의 무결성을 확인하십시오.

  • 답변 # 2

    해결책은 카드를 꺼내

    로 수정하는 것이 었습니다
     다른 컴퓨터에서. EightBitTony에서 제안한 매우 간단합니다.

    cannot remove '/usr/share/locale/locale.alias': Input/output error

관련 자료

  • 이전 bash 스크립트의 트랩 오류
  • 다음 backup - obnam에서 올바르게 작동하도록 gpg-agent를 구성하는 방법은 무엇입니까?