>

논리 볼륨 (및 ext4 파일 시스템)에 Linux 시스템 (Opensuse leap이지만 그렇게 중요하지는 않습니다)이 설치되어 있습니다. 최신 버전으로 업그레이드하고 싶지만 안전한 측면에서 문제가 발생할 경우를 대비하여 LVM 스냅 샷을 먼저 만들고 싶습니다.

현재 LV에는 이전 버전의 파일 시스템 (스냅 샷에서)과 새 버전 (업그레이드 후)을 모두 저장할 수있는 충분한 용량이 없습니다. LV에는 12GB가 있고 파일에는 8GB가 필요하고 4GB는 사용 가능합니다. LV를 일시적으로 20GB로 확장 할 수 있습니다. 이제 파일 시스템을 20GB로 확장해야합니까? 아니면 LVM에서 파일 시스템에 할당되지 않은 공간을 활용할 수 있습니까?

  • 답변 # 1

    실제로 스냅 샷에는 다른 LV를 사용합니다.

    합리적인 하우투가 있습니다 :

    https://www.tecmint.com/take-snapshot-of-logical-volume-and-restore-in-lvm/

  • 답변 # 2

    스냅 샷에는 (일부 메타 데이터 및) 사본이 포함됩니다 (원본 즉, 스냅 샷 생성 순간부터) 작성된 원본 볼륨의 일부. 따라서 작은 메타 데이터를 제외하고 스냅 샷 볼륨은 원래 볼륨보다 클 필요가 없습니다.

  • 이전 apt - 데비안이 제공하는 것보다 최신 버전의 소프트웨어를 어떻게 설치합니까?
  • 다음 bash - here-document를 사용할 때 파일에 텍스트를 쓸 수 없습니다