>

이 오류가 발생하기 시작했을 때 Fedora와 Ngnix를 설치하고 로컬 개발을위한 모든 구성 파일을 추가했습니다

nginx: [warn] could not build optimal types_hash, you should increase either types_hash_max_size: 2048 or types_hash_bucket_size: 64; ignoring types_hash_bucket_size
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

types_hash_bucket_size 를 추가해야한다는 솔루션을 찾았습니다.   nginx.conf 로 하지만 추가하고 기본 설정을 제거하고 둘 다 제거하고 둘 다 추가하면이 오류가 표시됩니다.

http {
    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';
    access_log  /var/log/nginx/access.log  main;
    sendfile                            on;
    tcp_nopush                          on;
    tcp_nodelay                         on;
    keepalive_timeout                   65;
    # I tried leaving both, removing both and one of each. The error persists.
    types_hash_max_size                2048;
    server_names_hash_bucket_size      128;

types_hash_max_size  nginx를 설치할 때 기본적으로 존재했습니다.

sites-enabled 에서 내 파일 :

server {
  listen 80;
  server_name devapi.hporder.com;
  root /home/gabriel/Sites/hp-order-system/workspace/api;
  client_max_body_size 10M;
  location ~ ^/(images|javascript|js|css|flash|media|static)/  {
    expires 30d;
  }
  location / {
    index  index.php index.html index.htm;
    try_files $uri $uri/ /index.php$is_args$args;
  }
  error_page   500 502 503 504  /50x.html;
  location = /50x.html {
    root   /usr/local/Cellar/nginx/1.10.1/html;
  }
  location ~ \.php$ {
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    fastcgi_param FF_BOOTSTRAP_ENVIRONMENT dev;
    fastcgi_param FF_BOOTSTRAP_CONFIG api/dev;
    fastcgi_pass 127.0.0.1:9000;
    fastcgi_index index.php;
    # include /usr/local/etc/nginx/fastcgi.conf;
    fastcgi_buffer_size 1024k;
    fastcgi_buffers 1024 1024k;
    fastcgi_busy_buffers_size 1024k;
  }
}


  • 답변 # 1

    Fedora 25에서도이 문제가있었습니다. 와이즈 비즈   types_hash_max_size 로 설정되었습니다  (nginx 문서는 기본값이 2048 임을 나타냅니다. ). 난 그냥 1024 로 증가  nginx는 행복했습니다 ( 4096 로 확인했습니다) ).

    FWIW, 내 구성에는 해시 버킷 크기와 관련된 설정이 없습니다. 기본값 일뿐입니다.

    nginx -t

  • 이전 hadoop - Oozie는 임의의 노드에서 쉘 스크립트를 실행합니다
  • 다음 profiling - cuda - 왜 많은 양의 gpu 유휴 시간이 있습니까?