>

Scala 2.13에만 사용할 수있는 종속성이있는sbt 플러그인을 개발하고 싶습니다.

https://github.com/sbt/sbt/issues/5032 이 목록 :

  • SBT 0.x runs only on Scala 2.10.x
  • SBT 1.x runs only on Scala 2.12.x
  • SBT 2.x will run only on Scala 2.13.x or 3.0.x
  • SBT 3.x will run only on Scala 3.0.x or Scala 3.1.x

마지막 두 줄은 저자mr-git이 추측 한 곳입니다.

실제로Scala 2.13버전이있는 경우 다른 접착제를 찾지 못했습니다.

아는 사람이 있습니까?

업데이트: 여기에 추가 : https://discuss.lightbend.com/t/when-is-there-a-sbt-version-for-2-13/5623

  • 답변 # 1

    운이 걱정된다면. 플러그인은 SBT와 바이너리 호환 가능해야합니다. 현재 SBT 1.x.x의 경우 2.12 또는 SBT 0.13.x의 경우 2.10을 의미합니다. 인터넷 어딘가에 SBT 2 버전의 흔적이 없습니다. 확실히 SBT GitHub 리포지토리에 그러한 버전이 없습니다

    이전의 상황은 스칼라 2.11과 비슷했습니다. sbt가 스칼라 2.11에 대해 구축됩니까?를 참조하십시오. sbt를 사용하여 스칼라 프로젝트를 만들 때 스칼라 버전의 관계는 무엇입니까?

  • 이전 dataframe - R에서 열 선택
  • 다음 bash - 명령 행 인수에서 변수가있는 문자열을 변수에 지정