>

코어를 8.9.0에서 8.9.1로 업데이트하려고했습니다. composer require drupal/core-recommended:8.9.1 하지만 다음과 같은 오류가 발생합니다.

Your requirements could not be resolved to an installable set of packages.
Problem 1
- Can only install one of: drupal/core[8.9.1, 8.9.0].
- Can only install one of: drupal/core[8.9.1, 8.9.0].
- Can only install one of: drupal/core[8.9.1, 8.9.0].
- drupal/core-recommended 8.9.1 requires drupal/core 8.9.1 -> satisfiable by drupal/core[8.9.1].
- Installation request for drupal/core-recommended 8.9.1 -> satisfiable by drupal/core-recommended[8.9.1].
- Installation request for drupal/core (locked at 8.9.0) -> satisfiable by drupal/core[8.9.0].

이것은 매우 혼란 스럽습니다. 드루팔/코어가 드루팔/권장으로 대체되었다고 생각 했습니까?


  • 답변 # 1

    나는 다시 시도했다 composer require drupal/core-recommended:8.9.1 --update-with-dependencies 그리고 코어를 업데이트하기 시작했습니다. 불행히도 drupal/core-composer-scaffold는 건드리지 않았으므로 추가 작곡가 명령으로 직접 업데이트해야했습니다.

    또한이 두 가지가 모두 업데이트되었음을 ​​알았습니다.

    - Updating drupal/core (8.9.0 => 8.9.1): Downloading (100%)
    - Updating drupal/core-recommended (8.9.0 => 8.9.1)
    
    

관련 자료

  • 이전 drupal - 하나의 역할 만 파일을 다운로드하도록 허용
  • 다음 drupal - 컨트롤러에서 POST 및 매개 변수로 리디렉션