>

어리석은 질문 인 것 같지만 ... 알 수 없습니다.

python2에서 다음과 같이 프로그램을 실행할 수 있습니다 :

python run.py

python3에서 다음을 사용하여 프로그램을 실행할 수 있습니다 :

python3 run.py

그러나

pip install pandas

Python2 용 팬더를 설치합니다

Python3 용으로 설치하려면 어떻게합니까?

내가 시도했다-

curl -O https://bootstrap.pypa.io/get-pip.py
python3 get-pip.py

이것은 pip를 설치하지만 프로젝트의 일부 요구 사항을 설치하려고 할 때 오류가 발생합니다 :

You are using pip version 9.0.3, however version 19.0.3 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.

다음을 사용하여 업그레이드 :

python3 -m pip install --upgrade pip

결과 :

Requirement already up-to-date: pip in /usr/lib/python3.6/site-packages (19.0.3)

감사합니다.


  • 답변 # 1

    as

    $ ls -1 /usr/bin/pip*
    /usr/bin/pip2
    /usr/bin/pip2.7
    /usr/bin/pip3
    /usr/bin/pip3.6
    
    

    실행해야합니다

    pip3 install pandas
    
    

  • 답변 # 2

    CMD 작성 :

    where pip
    
    

    그런 다음 :

    where pip3
    
    

    필자는 파이썬 \ sctips \에있는 경로 인 pip3을 사용해야한다고 생각합니다. pip의 Python3 버전입니다

    시도 할 수 있습니다 :

    pip3 install pandas
    
    

  • 답변 # 3

    언제나 pip를 모듈로 실행할 수 있습니다 :

    python2 -m pip <pip commands here>
    python3 -m pip <pip commands here>
    python3.6 -m pip <pip commands here>  # same as python3 as of this post
    python3.7 -m pip <pip commands here>
    
    

  • 이전 php - Symfony 4의 Symfony 3에 해당
  • 다음 hibernate - 런타임에 Spring UserDetails 오브젝트 가져 오기