>

자바를 업데이트 할 때 "프로젝트 패싯 Java 버전 1.7이 지원되지 않습니다"라는 문제가 발견되었습니다.  이 문제를 해결하려면 다음 단계를 따르십시오.

<올>
  • Ecllipse로 이동하여 프로젝트 폴더를 마우스 오른쪽 버튼으로 클릭하십시오
  • 속성을 ​​선택하십시오
  • 이제 프로젝트 패싯을 선택하십시오. 여기서 Java가 표시되면 버전을 클릭하고 상위 버전을 요구 사항에 따라 낮게 또는 변경하십시오.

    • 답변 # 1

      IDE에 어떤 유형의 JRE가 설치되어 있는지 확인해야합니다.

    • 답변 # 2

      업그레이드 할 때도 같은 문제가 발생했습니다 Java 버전 1.6에서 1.7까지 이 문제를 해결하기 위해 아래 단계를 수행했습니다.

      <올>

      프로젝트 탐색기에서 프로젝트를 마우스 오른쪽 버튼으로 클릭하고 속성을 클릭하십시오.

      Java 빌드 경로로 이동>"라이브러리"

      아이콘에 적십자 표시가있는 충돌하는 라이브러리를 삭제합니다.

      필요한 경우 JRE 시스템 라이브러리 Jar을 확인하고 편집합니다.

      프로젝트 패싯으로 이동하여 필요한 Java 버전을 선택하십시오.

      출처 : https://tipandtech.wordpress.com/2013/09/13/error-project-facet-java-version-1-7-is-not-supported-in-eclipse/

      아직 해결책을 찾지 못한 경우 사용해보십시오.

      Shishir

    • 답변 # 3

      나는 방금 같은 것을 가졌다. 내 솔루션은 설치된 JRE에서 1.6 JRE를 제거하고 Java 1.7 하나를 선택하는 것입니다.

      이것은 Window->Preferences->Java->Installed JRE에 있습니다.

      Boopathi가 말한 것처럼

    • 답변 # 4

      Tomcat 서버를 두 번 클릭->런타임 환경->설치된 jre->jdk 1.7 선택

    • 답변 # 5

      서버가 가리키는 jre 변경 (톰캣 또는 무엇이든 ...) JRE 대신 JDK를 가리킴

    관련 자료

  • 이전 google bigquery - Select 문에 일부 열에 CONCAT 기능이있는 경우 SQL 문은 어떤 순서로 실행됩니까?
  • 다음 android - 응용 프로그램로드시 소프트 키보드 숨기기