>

달릴 때nvidia-smi다음과 같은 메시지가 나타납니다.

Failed to initialize NVML: Driver/library version mismatch

1 시간 전에 동일한 메시지를 받고 내 cuda 라이브러리를 제거하고 다음을 실행할 수있었습니다.nvidia-smi, 다음 결과를 얻습니다.

이후 나는cuda-repo-ubuntu1604-8-0-local-ga2_8.0.61-1_amd64.deb...에서 공식 NVIDIA 페이지그리고 간단히 :

sudo dpkg -i cuda-repo-ubuntu1604-8-0-local-ga2_8.0.61-1_amd64.deb
sudo apt-get update
sudo apt-get install cuda
export PATH=/usr/local/cuda-8.0/bin${PATH:+:${PATH}}

이제 cuda를 설치했지만 언급 된 불일치 오류가 발생합니다.


잠재적으로 유용한 정보 :

달리기고양이 /proc /driver /nvidia /version나는 얻다:

NVRM version: NVIDIA UNIX x86_64 Kernel Module  378.13  Tue Feb  7 20:10:06 PST 2017
GCC version:  gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.4)

Ubuntu 16.04.2 LTS를 실행하고 있습니다.

커널 릴리스 : 4.4.0-66-일반.

감사합니다!

이전 실행 파일 설치를 (현재) 패키지 관리자 설치 (apt-get)와 혼합했을 수 있습니다. cuda linux 설치 가이드의 지침에 따라 이전의 모든 NVIDIA 드라이버 및 CUDA 파일을 제거한 다음 정리 한 후 다시 설치하십시오. 재설치를 시작하기 전에 내가 링크 한 전체 Linux 설치 가이드 문서를 읽어 보는 것이 좋습니다. 충돌은 거의 확실하게 기존 378.13 드라이버 설치 위에 CUDA 8 GA2 패키지를 설치하려는 시도에서 발생합니다.

Robert Crovella2021-03-30 03:42:04

이 질문은 기본적으로 프로그래밍과 직접 관련이없는 GPU 드라이버 설치 (또는 설치 중단)에 대한 질문이므로이 질문을 종료하는 데 투표합니다.

talonmies2021-03-30 16:54:04

@talonmies Stackoverflow가 아니라면 GPU 관련 질문을하기에 좋은 곳은 어디입니까?

bug_spray2021-03-30 20:44:28

Ubuntu를 사용하고 있으며 Linux에서 Nvidia 드라이버를 업데이트 한 후 오류가 발생한다고 생각합니다. Nvidia 드라이버를 업데이트 한 후 자동 제거 및 재부팅이 필요할 수 있습니다.

lechat2021-03-30 21:27:40

관련 자료

  • 이전 reporting services - 왼쪽과 오른쪽에 행당 2 개의 레코드가 가능하도록 레코드를 어떻게 반복 할 수 있습니까?
  • 다음 Micronaut와 함께 여러 개의 요청 매개 변수 @PathVariable 및 @RequestAttribute?