>

' git status 를 사용할 때 Xcode 버전을 7.3.1로 업데이트했습니다. ', 오류가 있습니다! 다음과 같이 :

$git status
sh: line 1:  1601 Segmentation fault: 11  /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild -sdk / -find git 2> /dev/null
git: error: unable to find utility "git", not a developer tool or in PATH

고맙습니다!

  • 답변 # 1

    가장 좋은 해결책은 다운로드하여 설치하는 것입니다-이미 설치되어 있다고 가정하더라도 https://git-scm.com/download/mac

  • 답변 # 2

    같은 문제가 있습니다- -내 bash 세션을 종료하고 (터미널을 닫은 후) 새 세션을 시작하고 수정했습니다.

  • 답변 # 3

    High Sierra 및 XCode로 9로 업그레이드하여 나에게도이 문제가 해결되었습니다.

    xcode-select --install
    sudo xcode-select -s /Library/Developer/CommandLineTools
    
    

    이 답변을 https://davidwalsh.name/fix-git-high-sierra-upgrade에서 찾았습니다. (기사 및 의견)

  • 답변 # 4

    나를 위해 모든 brew 를 제거하고 다시 설치해야했습니다.  여기에 설명 된대로

    즉,

    brew list -1 > brew.txt # list out all installed packages
    brew list -1 | xargs brew rm --force # remove all installed packages
    brew install $(cat brew.txt | tr '\n' ' ') # install all previously installed packages
    
    

  • 이전 중첩, 존재, 존재하지 않는 쿼리를 결합한 Elasticsearch curl 쿼리
  • 다음 version control - Perforce에서 열려있는 모든 파일을 어떻게 되돌릴 수 있습니까?