>

OS : CentOS Linux 릴리스 7.7.1908 (코어) [3.10.0-957.27.2.el7.x86_64]

yum 업그레이드/업데이트를 수행했으며 업데이트 할 항목이 없으며, azerothcore-wotlk에 대한 git pull을 완료했으며 업데이트 할 항목도 없습니다.

[azerothcore-wotlk] $도커 작성

오류 : "./docker-compose.yml"의 버전이 지원되지 않습니다. 잘못된 작성 파일 버전을 사용하고 있기 때문에이 오류가 표시 될 수 있습니다. "2"(또는 "2.0") 버전을 지정하고 서비스 정의를 services 아래에 두십시오.  키 또는 version 를 생략  키를 누르고 서비스 정의를 파일의 루트에 배치하여 버전 1을 사용하십시오. 작성 파일 형식 버전에 대한 자세한 내용은 https://docs.docker.com/compose를 참조하십시오./compose-file/

[azerothcore-wotlk]$ head docker-compose.yml
version: '3.2'
services:
  ac-database:
    image: azerothcore/database
    build:
      context: .
      dockerfile: ./docker/database/Dockerfile
    networks:

[azerothcore-wotlk] $도커 작성 --version

도커 작성 버전 1.9.0, 빌드 2585387

[azerothcore-wotlk] $도커-버전

Docker 버전 19.03.2, 빌드 6a30dfc

  • 이전 python - 구문 트리를 재귀 적으로 걷기
  • 다음 입력으로 단어 (소문자)를 요청하고 단어를 Pig Latin로 변환하는 Python 프로그램 작성