>

Google Maps API 작업에 사용하던 이전 애플리케이션이 있습니다. 마지막으로 성공한 빌드 이후 코드를 변경하지 않았지만 이제는 앱을 다시 빌드 할 수 없습니다.

"com.google.android.gms : play-service-maps : 11.8.0"라이브러리에 종속성을 추가하려고하면 Android Studio가 인터넷에서 필요한 파일을 다운로드하려고합니다. 대략 50 %에 도달하면 "com.google.android.gms : play-services-maps : 11.8.0 종속성을 찾을 수 없습니다"라는 오류가 표시됩니다.

이러한 이유와 문제 해결 방법을 아는 사람이 있습니까?

  • 답변 # 1

    버전을 11.8.0에서 이전 버전으로 변경하십시오. (예 : 11.0.2)

  • 답변 # 2

    Choose_Library_Dependency 대화 상자에 이미 지정된 Google Play 서비스에 대한 종속성을 추가하는 것이 좋습니다. 이 일은 항상 나를 위해 일했습니다. 옵션을 살펴보면 Google Play 서비스와 일치하는 것을 찾을 수 있습니다. 거기에 지정된 버전이 무엇이든 Google 맵 종속성에서 동일한 버전을 사용해야합니다.

    스크린 샷

  • 답변 # 3

    Google Play 서비스 버전은 compileSdkVersion 에 따라 다릅니다.  당신의 build.gradle 에서

    시도 :

    com.google.android.gms:play-services-maps:11.0.4
    
    

    SDK 버전을 최신 버전으로 업데이트하십시오.

  • 답변 # 4

    implementation "com.google.android.gms:play-services:15.0.0" 변경 후    implementation "com.google.firebase:firebase-invites:15.0.0 로 앱을 성공적으로 빌드했습니다.

  • 이전 numpy - Cython에서 배열의 합 배열
  • 다음 oracle - 4 개의 테이블을 조인하여 SQL 테이블 업데이트