>

IE11 (그리고 슬프게도)을 지원하고 싶었다면 어떻게 gatsby develop 를 만들 수 있을까요?  저 오래된 브라우저에서 작업 하시나요?

지금이 메시지가 나타납니다 :

webpack-hot-middleware's client requires EventSource to work.

이 폴리 필은 유망한 것 같습니다 . 그러나 그것은 내가 한 것입니다.

도움이 있습니까?

P.S. 아마 Gatsby v 2.4.7을 사용하고 있다고 언급 할 가치가 있습니다.

  • 답변 # 1

    개츠비 문서에 따르면 babel 7을 사용해야합니다.

    Babel은 작성한 JavaScript가 다른 브라우저 (이전 버전의 Internet Explorer 포함)에서 작동하도록합니다.

    참조 :

    벨벳 7 (개츠비)

    Gatsby는 Babel 7의 기능으로 대상 브라우저에 대한 폴리 필을 자동으로 추가 할 수 있습니다

    최신 브라우저는 이전 브라우저보다 더 많은 JavaScript API를 지원합니다. 이전 버전의 경우 Gatsby (Babel을 통해)는 코드가 해당 브라우저에서 작동하는 데 필요한 최소 "폴리 필"을 자동으로 추가합니다.

    일부 타겟 브라우저에서 지원하지 않는 [] .includes와 같은 최신 JavaScript API를 사용하기 시작하면 Babel이 필요한 폴리 필 코어를 자동으로 추가하므로 이전 브라우저를 중단 할 염려가 없습니다. -js/modules/es7.array.includes

    참조 :

    브라우저 지원

  • 답변 # 2

    개츠비가 개발 과정에서 IE 만 지원하지 않는 것처럼 보입니다. 프로덕션 환경에서만 폴리 필이 추가되지 않고 gatsby develop 를 사용할 때 IE 오류가 발생합니다 .

    https://www.gatsbyjs.org/packages/babel-preset-gatsby/

  • 이전 javascript - 파일 입력 필드에 모든 Excel 형식을 허용하는 방법
  • 다음 javascript - 이벤트를 기반으로 완료 될 때까지 Observable에서 N 값을 가져옵니다 다중 선택 목록 지연 로딩