>

react-native run-android 를 사용하여 Ubuntu 16.04 PC에서 React Native 프로젝트를 실행하려고합니다.  명령. 그러나 다음과 같은 오류가 발생합니다.

이상한 것은 API Studio 23 용 Android Studio를 사용하여 Android 프로젝트를 생성하고 실행하면 컴파일되고 완벽하게 실행된다는 것입니다.

이 문제를 도와 줄 사람이 있습니까?

  • 답변 # 1

    빌드 툴 버전 23.0.1이 설치되어 있는지 확인 했습니까? SDK 관리자에서 확인할 수 있습니다

  • 답변 # 2

    Gradle 버전을 업그레이드하면 문제가 해결되었습니다. 다음 단계를 거쳤습니다.

    <올>

    React Native 프로젝트 내에서 안드로이드 폴더를 열었습니다. 안드로이드 스튜디오.

    버전을 업데이트하라는 메시지가 표시됨 Gradle.

관련 자료

  • 이전 자바 스크립트를 사용하여 Json에서 데이터 가져 오기 (jsonplaceholder)
  • 다음 동일한 변수를 사용하는 Python 암호화 라이브러리 해독으로 InvalidTag 제공